SCM

[#315428] Error when connecting to scanner device 'Canon MG5300 series' via network

View Trackers | Bugs | Export CSV

Date:
2016-07-21 11:52
Priority:
3
State:
Closed
Submitted by:
Juergen Werner (pipeline-guest)
Assigned to:
Louis Lagendijk (llagendijk-guest)
Category:
backends (drivers)
Group:
None
Resolution:
Fixed
Summary:
Error when connecting to scanner device 'Canon MG5300 series' via network

Detailed description
When I try to scan over the network with any frontend what is using the Sane environment I get the error that connecting to my scanner is not possible. For example when I use 'Simple Scan' or 'XSane'.

XSane reports the following message:
Error when opening device 'pixma:MG5300_<IP-number>': Invalid Argument.

Simple Scan reports this message:
Connection to the scanner could not be established.

They all detect the scanner without problem. I have tested it with disabled firewall and I created firewall rules that open incoming connections via ports 8610, 8611 and 8612. I have done everything what is described in this document:

http://www.sane-project.org/man/sane-pixma.5.html

I have also installed original Canon Driver 'scangearmp'. With this frontend scanning works well and I can use Gimp with it, because gimp can use it directly. But all software that uses Sane fails to connect.

Hope you can fix it.



Followups: Sort comments antichronologically

Message
Date: 2016-07-28 17:43
Sender: Juergen Werner

Btw, the original canon drivers which can be downloaded from their support site do not work, they are simply to old. I have used the drivers from the following websites:

https://launchpad.net/~inameiname

and/or

https://launchpad.net/~michael-gruz
Date: 2016-09-25 13:57
Sender: m. allan noah

You might find that the problem is scangearmp keeping the device open, and preventing sane from accessing it. Try removing it temporarily, and see if that helps.
Date: 2016-09-26 04:03
Sender: Juergen Werner

This is not the case. I use scangearmp because sane does not work. With other words: I tried sane first, after I found that it does not work I started surching for drivers on the net. As I said before, the original canon drivers do not work, because they are to old. Than I found this private person who offers drivers:
https://launchpad.net/~michael-gruz

Btw. The exact printer name is Canon PIXMA MG5350. I have the latest firmware installed.
Date: 2016-09-26 16:41
Sender: Louis Lagendijk

What is the version of sane-backends you are using? This issue sounds similar to the issue I fixed in commit 43bca22e0cc9ad7e2024a4f97be7250aa72c7992. The fix is included in sane 1.0.25. If you are using 1.0.25, I need the output of the logfile of sacanimage (after setting export SANE_DEBUG_PIXMA=5 in bash) AND the wireshark trace for the scannner.
Louis
Date: 2016-10-01 14:40
Sender: Juergen Werner

Sorry, I am new to Linux. It may take some time until I have everything together what you need for fixing.

I have found that

sane-utils API-library 1.0.25+git20150528-1ubuntu2

is installed.

Rest will follow after I have found my way in. :-)




Date: 2017-04-14 10:38
Sender: Stefan Gutschireiter

I have the exact same problem with my Canon MG4250.
Scanning via scangearmp works perfectly.
sane detects the scanner, but when trying to scan i get "Error when opening device 'pixma:MG5200_<IP-number>': Invalid Argument."
I also tried to configure the IP in pixma.conf with the same result.
I am using sane 1.0.25 with Ubuntu Zesty.
Maybe this printers use a different protocol ?
Date: 2017-04-14 15:46
Sender: Louis Lagendijk

There are a nuber of things to check:
- Does the scanner work over USB?
- Are you using a recent GIT snapshot (1.0.26)? If not, try the latest beta version, as I mentioned aove I fixed an error that has this effect some time ago. This fix may not yet be included in the sane version you are using.
If it works over USB I need a logfile (see the man page):
export SANE_DEBUG_PIXMA=11
scanimage > tt 2> log
and please get e the resulting log file

Thanks, Louis
Date: 2017-04-15 02:32
Sender: Stefan Gutschireiter

So i did some tests an can confirm (Canon MG4250):
scanner is working with 1.0.25 and USB

i downloaded the sane git tree and compiled the current version and can confirm - with this version the scanner is working over WLAN too

hopefully ubuntu will update their packets soon ...

thanks
Date: 2017-05-05 18:49
Sender: Louis Lagendijk

Thanks for the report.
This bug is fixed in git now.

Attached Files:

Changes:

Field Old Value Date By
status_idOpen2017-05-05 18:54llagendijk-guest
close_dateNone2017-05-05 18:54llagendijk-guest
ResolutionNone2017-05-05 18:50llagendijk-guest
assigned_toroben-guest2016-09-26 16:11roben-guest
assigned_tonone2016-09-25 13:57kitno-guest
CategoryNone2016-09-25 13:57kitno-guest
Powered By FusionForge