SCM

[#315839] Samsung Xpress M2885FW fails to scan image

View Trackers | Bugs | Export CSV

Date:
2017-09-19 19:55
Priority:
3
State:
Open
Submitted by:
Jan Christoph Ebersach (jceb-guest)
Assigned to:
Alex Belkin (abc-guest)
Category:
scanimage
Group:
None
Resolution:
None
Summary:
Samsung Xpress M2885FW fails to scan image

Detailed description
I use sane 1.0.27 on Arch Linux and set up the scanner in xerox_mfp.conf as a network scanner via TCP. scanimage -L recognizes the scanner properly:

device `xerox_mfp:tcp xpress.xxxx.yyyy' is a Samsung M288x Series multi-function peripheral

The scanner actually tries to scan the document and it appears to be successful. However, the scan fails with the following error message:
> scanimage --format png -d 'xerox_mfp:tcp xpress.xxxx.yyyy' > /tmp/test.png
Not a JPEG file: starts with 0x00 0x00

Followups: Sort comments antichronologically

Message
Date: 2017-11-18 03:10
Sender: Olaf Meeuwissen

Looks like a duplicate of 315876.
Date: 2017-11-19 07:43
Sender: Olaf Meeuwissen

Don't know if this is related but I came across a mention of the same symptom on Ubuntu's Launchpad here

https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1728012/comments/24
Date: 2017-11-20 09:54
Sender: Olaf Meeuwissen

There's also a bug report that suggests a similar solution.

https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1724078

The initial two bytes are different but I think that their values are just raw RGB data and not relevant to the problem at hand.

Attached Files:

Attachments:
Size Name Date By Download
5 KiBscanimage.log2017-09-19 19:55jceb-guestscanimage.log

Changes:

Field Old Value Date By
assigned_tonone2017-11-18 03:10olaf-guest
File Added7584: scanimage.log2017-09-19 19:55jceb-guest
Powered By FusionForge